1. Home
  2. MapEdit AppBuilder
  3. AppBuilder – Dialog Designer

AppBuilder – Dialog Designer

In dieser Rubrik haben sie die Möglichkeit Dialoge neu zu erstellen oder es wurden entsprechend Dialoge aus einer Autodesk Map Definition zu übernommen.

Funktionen Dialog Designer

Auf/Zu-klappen

Mit dieser Funktion öffnen und schließen Sie die unter dem Dialog Designer gespeicherten Einträge. Die Einträge entsprechen den Definitionen aus dem Repositorium Datenbanken.

Dialoge Synchronisieren

Das „Dialoge Synchronisieren“ muss immer dann ausgeführt werden, wenn man in Autodesk Map mit dem TB Admin im  Form Designer Änderungen an den Dialogen gemacht hat. Denn MapEdit weiß von diesen Änderungen nichts und zeigt dann weil die Dialoge gecached sind alte Versionen dieser Dialoge an.

Sind Dialoge im Form Designer von MapEdit erzeugt worden, muss diese Funktion nicht ausgeführt werden.

Dialog Positionen/Groessen als Vorlage speichern

Führt man diesen Befehl aus, werden alle Dialoge aller Projekte die der Administrator auf der Maschine, wo der AppBuilder installiert ist, als Vorlage gespeichert.

Jeder Benutzer hat einen anderen Rechner und damit eine andere Bildschirmgröße und ggf mehrere Bildschirme, eine andere Anzahl von Bildschirmen / Größen und andere Auflösungen.

Wenn ein Anwender einen Dialog zum aller aller ersten mal aufmacht, bekommt er die Größe die der Admin im App Builder vorgegeben hat.
Dies macht der Admin in dem er die Dialoge bei seiner Maschine im Client (oder Professional) aufmacht und so hin zieht wie er es will. Dann drückt er im App Builder den Knopf „Dialog Positionen/Groessen als Vorlage speichern“

Der Admin kann durch diese Aktion nicht die Position der Dialoge beeinflussen die die Anwender schon in Benutztung haben. Dies wird auf dem Server hier gespeichert:
C:\inetpub\wwwroot\MumGeoData\Repositories\Default\Projects\ NAME DES PROJEKTS.FormDefaults.sbt
In dieser Datei stehen alle Vorgabenwerte für alle Dialoge eines Projektes.

Nach diesem Zeitpunkt merkt sich das Programm die Größe und Position der Dialoge bei jedem Schliessen der Dialoge (nicht bei einem Absturz) und zwar für jeden Rechner lokal und jedes Projekt.

Dies wird lokal auf dem Rechner im Client Cache gespeichert.

Das Verzeichnis des Clientcaches findet man im Client unter Optionen ->Datenspeicher Button „Clientseitigen Speicherordner“ öffnen.
Oder über CTRL+F12 das Log Fenster öffnen. Nach unten scrollen da steht unten „ApplicationDataPath“ und dahinter der Pfad.

Die letzten Werte jedes Dialoges findet man in diesem Verzeichnis unter
Project\ NAME DES PROJEKTS \UserData\Forms\ Datenbankverbindung.Tabelle.Template.sod. Für jeden Dialog gibt es dort eine Datei.

Wird diese Datei gelöscht weil jemand den „Clientseitigen Datenspeicher leeren“ Knopf drückt oder aus welchen anderen Gründen auch immer löscht, dann ist die letzte Einstellung weg.

Datenbankverbindung

Wenn Sie eine Datenbankverbindung markieren erhalten Sie folgende Funktionen. Erklärung der Funktionen weiter unten oder oben.

Funktionen der DB Verbindung

Dialogverarbeitung

Beim Öffnen der Dialoge der DB-Verbindung erhalten Sie diese Funktionen

Funktionen der Dialogbearbeitung

Dialoge kopieren

Wenn Sie diese Funktion ausführen müssen Sie entscheiden auf welche Datenbankverbindung Sie die Dialoge kopieren wollen. Und erhalten eine entsprechende Auswahlbox.

Auswahlbox Datenbankverbindung

Datenbanknamen ändern

Meldung bei Datenbanknamen ändern

Im Form Designer kann man bei den Comboboxen eine andere Datenbankverbindung angeben als die Datenbankverbindung des Dialoges. Diese Einstellung ist bei jeder Combobox möglich. Es gibt jedoch Varianten bei denen Kennungslisten in einer separaten Datenbank abgespeichert sind. Man hat zum Beispiel einen Dialog auf Flurstück aus dem User ALK, aber die Kennungsliste Straßennamen in diesem Dialog kommt aus dem User BASIS. Will man Dialoge an andere Kunden geben, oder man will diese bei einem anderen Projekt verwenden, kann der Anwender diese Verbindung auf eine andere Datenbank umändern. Oder das Projekt soll nicht den User BASIS benutzten oder hat den gar nicht, dann kann der Anwender diese Verbindung auf eine andere Datenbank umändern.

Exportieren

beim Export gibt es zwei Varianten des Exports

Export Varianten

In der Folge erhalten Sie eine Auswahlbox der zur verfügung stehenden Dialoge

Auswahlbox der zur Verfügung stehenden Dialoge

Dialoge exportieren: Daten werden in eine zur Auswahl stehenden Datei *.dialogs gespeichert. Titel exportieren: Daten werden in eine zur Auswahl stehenden Exceldatei *.xlsx gespeichert.

Importieren

beim Import gibt es zwei Varianten des Imports

Import Varianten

Dialoge importieren: Programm sucht eine Datei Namens *.dialogs die über den Export erstellt wurde. Zuvor werden Sie jedoch noch gefragt ob eine Datensicherung existiert. Titel importieren: Programm sucht nach einer Datei Namens *.xlsx die über den Export erstellt wurde.

Alle Dialoge Serialisieren

„Alle Dialoge Serialisieren“  ist eine temporäre Lösung um alle Dialoge aus einer Datenbank zu serialisieren. Also um diese in eine Filestruktur zu speichern. Der Grund für die Implementierung ist MapEdit Mobile. MapEdit Mobile hat derzeit keinen direkten Zugriff auf eine Datenbank sondern nur über das Backend. Und dort fehlt im Moment so eine Funktion.

Hat für Kunden im Moment keinen Mehrwert und sollte daher von Kunden nicht verwendet werden. Daher nur für Entwickler zugänglich.

Formular Designer

Beim öffnen des Formular Designers erhalten Sie folgende Auswahlmöglichkeiten

Sie können hier ihre Auswahl treffen ob sie die Daten nach Topic’s / Tabellen / Titel / Typ aufgelistet haben möchten. Wenn Sie bestiimmte Formulare öfters bearbeiten müssen oder wollen gibt hierzu den Favoriten Schalter. Wenn Sie bestimmte Formulare markieren und den Schalter mit dem Herz aktivieren erhalten die markierten Formulare unter Favorit.

Bei Betätigung des Filter Buttons bekommen Sie ein Eingabefeld eingeblendet in dem Sie Ihren Filter definieren können.

Ein weiterer wichtiger Punkt sind die verschiedenen Funktionsbuttons auf der rechten Seite des Formular Designers.

Funktionsbuttons Formular

Hier haben Sie folgende Auswahlmöglichkeiten

  • Öffnen eines ausgewählten Formulars
  • Gruppen Zugriffsrechte zu definieren
  • Neues Formular hinzufügen ( Nur für MapEdit Desktop)
  • Neues Formular hinzufügen ( Nur für MapEdit Mobile )
  • Ausgewähltes Formular klonen
  • Ausgewähltes Formular löschen

Wenn Sie ein bestimmtes Formular markieren erhalten Sie folgende Darstellung und sehen was für Dialoge auf einer Tabelle definiert sind und zur weiteren Bearbeitung zur Verfügung stehen.

Auswahl der Dialoge

Durch Doppelklick wird der auf der rechten Seite markierte Dialog zur Bearbeitung geöffnet.

Dialog Bearbeitungsfenster
Menüpunkte Extras

Reiter Edit

Folgende Bearbeitungsmöglichkeiten stehen unter Menüpunkt Edit zur Verfügung:

Menüpunkte Editierung

Vorschau In der Vorschau erhalten Sie die Ausprägung des Dialog’s wie er in MapEdit zu sehen ist

Steuerelement Eigenschaften Markieren Sie ein Feld auf der rechten Seite dann können bei den Eigenschaften des Feldes 5 verschiedene Eigenschaften spezifiziert werden. Durch aktivieren verschiedener Schalter in den 5 Eigenschaften steuern Sie z.Bsp bei Allgemein ob es sich um Pflichtfeld handelt oder nicht.

Steuerelemente Bei diesem Ribbon bekommen Sie eine Übersicht der dargestellten und unsichtbaren Elemente des Dialogs hinter dem eine View oder eine Tabelle sich verbirgt.

Wenn Sie ein Feld das noch nicht im DIalog sichtbar hinzufügen wollen, markieren Sie mit gedrückter linken Maustaste in der Tabelle HIDDEN das gewünschte Feld und ziehen es auf die rechte Seite. Durch Verschieben mittels Maus platzieren Sie das Feld an die gewünschte Stelle.

Automatisch einrasten Ist diese Schaltfläche aktiviert werden beim Verschieben der Felder die Felder in der vertikalen und horizontalen Position eingerastet, so dass die Felder untereinander die gleichen Abstände aufweisen.

Neuen Tab hinzufügen Durch Betätigen dieser Funktion fügen Sie dem Dialog eine weitere Karteikarte hinzu, wobei Sie die Bezeichnung frei wählen können.

In die neue Karteikarte werden alle Felder übernommen die in der Karteikarte „All“ vorhanden sind. Durch markieren eines Feldes mit der rechten Maustaste bekommen Sie eine dreifache Wahlmöglichkeit um das Feld in eine andere Kartei zu verschieben um auszublenden oder die Eigenschaften aufzurufen.

Tab löschen Mit dieser Funktion können Sie eine Karteikarte wieder aus dem Dialog entfernen

Tab bearbeiten Mit dieser Funktion können Sie eine Karteikarte umbenennen

Alle auswählen Mit dieser Funktion werden alle Felder auf der rechten Seite markiert und man könnte z.Bsp mit der Funktion „Um Steuerelement rotieren“ alle Beschriftungen um ihre Felder rotieren lassen.

Auswahl löschen Diese Funktion ist nur aktiv wenn Sie ein Referenzfeld markiert haben. Danach wird dieses Feld komplett aus dem Dialog entfernt. Wenn sie mit dieser Funktion ein Feld der darunterliegenden Tabelle markiert haben, erhalten Sie folgende Meldung

Um Steuerelement rotieren Mit dieser Funktion können Sie die Beschriftung des Feldes um jeweils 100gon um das Feld rotieren lassen.

Auswahl ausblenden Wenn Sie diese Funktion anklicken wird dass auf der rechten Seite markierte Feld aus dem Formular entfernt und ist in der Aufzählung HIDDEN wieder zu finden.

Auswahl einblenden

Verborgene erspähen Mit dieser Funktion machen Sie Felder die zuvor während der Bearbeitung eingefügt und wieder entfernt wurden kurzfristig sichtbar solange sie mit der Maustaste gedrückt auf dieser Funktion verweilen. Diese Funktion ist aber nur während der Bearbeitung eines Dialogs aktiv. Nach Speicherung des Dialogs erscheinen die Felder nicht mehr.

Alle ausblenden Mit dieser Funktion werden alle Felder aus Ihrem Dialog entfernt.

Alle einblenden Mit dieser Funktion werden alle Felder auch die aus HIDDEN in den Dialog eingefügt.

Nach Typ verbergen Mit dieser Funktion bekommen Sie eine Auswahl aller möglichen Steuerelemente die Sie auswählen können um gefiltert Felder zu verbergen.

Eins hoch Sind die Felder vertikal angeordnet können mit dieser Funktion Felder um eine Position nach oben verschoben werden. Gibt es horizontal und vertikal angeordnete Felder wird von links nach rechts verschoben.

Eins runter Sind die Felder vertikal angeordnet können mit dieser Funktion Felder um eine Position nach unten verschoben werden. Gibt es horizontal und vertikal angeordnete Felder wird von links nach rechts verschoben.

Abstand schließen Ist der Funktion „Automatisch einrasten“ eingeschaltet kann mit dieser Funktion ein Feld auf ein anderes Feld mit sichtbarem Abstand angehängt werden.

Abstand erzeugen Wenn die Funktion „Automatisch einrasten“ ausgeschaltet war kann man mit dieser Funktion die Felder auf einen sichtbaren Abstand einrasten lassen.

Links ankern Wurde ein Feld aus der HIDDEN Liste in den Dialog eingefügt lässt sich ein Feld auf der linken Seite verankern.

Linksbündig Sind mindestens zwei Felder im VISIBLE markiert

können diese Felder linksbündig angeordnet werden

Rechtsbündig Dieselbe Funktion wie Linksbündig nur das die Felder rechtsbündig angeordnet werden.

Mittig Mit dieser Funktion werden die Felder mittig im Dialogfenster angeordnet. Wobei die Feldbeschreibung nicht berücksichtigt wird.

Durchschnittsbreite Mindestens zwei Felder müssen in VISIBLE markiert sein nachdem die Felder in den Dialog eingefügt wurden. Wenn die Felder unterschiedliche Länge haben wird mit dieser Funktion eine Durchschnittsbreite ermittelt und positioniert.

Reiter Toolbox

Folgende Bearbeitungsmöglichkeiten stehen unter Menüpunkt Toolbox zur Verfügung:

Menüpunkte Toolbox
Vorschau

In der Vorschau erhalten Sie die Ausprägung des Dialog’s wie er in MapEdit zu sehen ist.

Label

Mit der Funktion Label können Sie einen beliebigen Text in Ihren Dialog einbauen.

Ergebnis

Text Box

Mit der Funktion kann ein Textfeld für die Eingabe eines Textes ausgewählt werden. Zur Auswahl bekommt man die Felder der Tabelle / View die dahinter definiert ist.

Dateiauswahl: Gibt an, dass auf eine externe Datei verwiesen wird. Standard = False. Legen Sie diese Eigenschaft auf True fest, um auf eine externe Datei, z. B. ein Bild, zu verweisen. Zwei zusätzliche Schaltflächen werden angezeigt. Einer wählt die Datei aus, der andere zeigt die Datei mit der zugehörigen Anwendung an (z. B. eine *.docx mit Microsoft® Word).

Filterliste: Gibt an, dass ein Filterlistenfeld angezeigt wird. Standard = False. Legen Sie diese Eigenschaft auf True fest, um festzulegen, dass im Filtermodus ein Listenfeld angezeigt wird, in dem der Benutzer die Elemente auswählen kann.

Combo Box

Grundlegende Eigenschaften eines Kombinationsfelds: Ein Kombinationsfeld verfügt immer über einen Dropdownpfeil, mit dem Sie einen Eintrag auswählen können. Wenn das zugehörige FEATURE über Geometrie verfügt, können Sie optional eine FID-Auswahlschaltfläche festlegen, um das zugehörige Objekt in der Karte zu identifizieren und zuzuweisen, und eine Schaltfläche Hervorheben, um das zugehörige Objekt in der Karte hervorzuheben.

Dieses Steuerelement wird häufig für Domänentabellen verwendet. Wenn ein Formular erstellt wird, erhält jedes Attribut mit einer Beziehung zu einer Domäne ein einfaches Kombinationsfeld. Alle Einträge werden analysiert.

Sie bestimmen welche Verbindung / Tabelle / Schlüssel / Anzeige sie der Combobox zuordnen wollen.

Detail Tabelle: Die Detailtabelle kann sich auch in einem Dokument befinden, das nicht das aktuelle Dokument ist.

Detail Anzeige Wert: Attribut, das im Formular angezeigt werden soll, z. B. VALUE. Verwenden Sie beispielsweise ID-|| ‚ – ‚ || VALUE, um sowohl ID als auch VALUE anzuzeigen. Bei Domains wird in der Regel die ID aufgelistet. Es ist sinnvoll, dies in WERT zu ändern, da dies klarer ist.

Master Box

Ein Erweitertes Combobox-Steuerelement (Masterbox) ist ein Add-On zu einem Kombinationsfeld. Sie können ein erweitertes Kombinationsfeld sowohl mit einem einfachen Kombinationsfeld als auch mit einem anderen erweiterten Kombinationsfeld im aktuellen Formular verknüpfen. Daher können Sie mehrere Dropdownlisten verketten und mehrere Beziehungen nachverfolgen, wie in der folgenden Tabelle dargestellt:

Master Liste: Anzeigeattribute: Wird in der Dropdown-Liste des Masterfelds angezeigt, z. B. NUMMER

Check Box

Mit der Checkbox hat man die Möglichkeit ein sogenanntes ja / nein Feld zu definieren.

False Value: Definiert einen Wert, der im Formular angezeigt werden soll, wenn der Datenbankwert 0 oder NULL ist. Beispiel: Nein, Schließen oder Falsch.

NullValue: Gibt einen Standardwert an, der eingefügt wird, wenn Sie einen neuen Datensatz hinzufügen. Sie können dies auch für den AutoIncrement-Wert oder Datum/Uhrzeit und zum Erstellen von GUIDs verwenden.

TrueValue: Definiert einen Wert, der im Formular angezeigt werden soll, wenn der Datenbankwert 1 ist. Beispiel: Öffnen, Wahr oder Ja.

Reference

Über die Referenz kann auf eine andere Datenbank (Detail Datenbank) zugegriffen werden um dort die Daten abzufragen. Das Reference-Steuerelement generiert zwei Schaltflächen: die Schaltfläche Referenz und die Schaltfläche Projektion. Wenn der Benutzer auf die Schaltfläche Referenz drückt, wird das Formular der zugehörigen Tabelle geöffnet, wobei ein Filter auf den aktuellen Datensatz festgelegt ist.

ProjektionButton: True = eine Projektionsschaltfläche wird generiert. Dies ist die Standardeinstellung.

ReferenceButton: True = eine Referenzschaltfläche wird generiert. Dies ist die Standardeinstellung.

Formula

Im Formeleditor können Sie die verfügbaren Funktionen in einem Listenfeld auswählen, das nach Eingabe von „ich“ erscheint. Das Ergebnis der Formel wird immer der Variablen „ergebnis“ zugeordnet.

Formula: Durch Anklicken des … Punkte Buttons in den Eigenschaften bei Formula kann eine Formel mit Hilfe des SQL-Editors definiert werden. Sie können eine Formel mithilfe der Datenbankattribute und aller gültigen VB .NET-Codes erstellen.

SQL Label

Verwenden Sie das schreibgeschützte SQL TextBox-Steuerelement (SqlLabel), um Text im Feature-Class-Formular anzuzeigen, der mit einer SQL-Anweisung abgefragt wird. Sie können auch Daten aus verschiedenen Attributen und Tabellen abfragen und anzeigen. Testen Sie die SQL-Anweisung im SQL-Editor.

Mit Klick auf Sql bei den Eigenschaften öffnet sich der SQL Editor in dem Sie Ihren SQL formulieren können. Bei der Eingabe des SQL’s wird durch Klick auf OK eine Plausibilitätsprüfung vorgenommen.

SQL Textbox

Verwenden Sie das Steuerelement Editable SQL TextBox (SqlTextBox), um das Ergebnis einer SQL-Abfrage anzuzeigen, z. B. den Bereich, der in einer anderen Tabelle gespeichert ist. Es wird empfohlen, diesen Steuerelementtyp nur zu verwenden, wenn Sie ein einzelnes Attribut abfragen. Wenn Sie den Wert nicht bearbeiten und nur anzeigen möchten, wird empfohlen, das schreibgeschützte SQL TextBox-Steuerelement zu verwenden, das eine bessere Leistung aufweist.

Beachten Sie den Unterschied zwischen schreibgeschützter SQL-TextBox und bearbeitbarer SQL-TextBox. Indem sie den Schalter Sperren setzen, wird die SQL TextBox schreibgeschützt. Ist SQL TextBox editierbar in dem der Wert bearbeitet werden kann, wird der Wert gespeichert.

DetailFieldname: Gibt das Attribut (das aus der Detailtabelle ausgewählt werden soll) an, das Sie anzeigen möchten.

DetailFilter: Der Filterausdruck für die select-Anweisung (ohne WHERE-Ausdruck). Klicken Sie auf den Dreipunkteschalter , um den SQL-Editor zu öffnen. Verwenden Sie den SQL-Editor, um die filter-Anweisung zu erstellen. 

DetailTabelle: Gibt die Tabelle an, aus der Sie Daten auswählen möchten.

Geometry

Verwenden Sie das Steuerelement Koordinaten-Editor (Geometrie), um Geometrie und Koordinaten von Punkten, Linien und Polygonen anzuzeigen. Indem Sie in den Eigenschaften den Select hinterlegen der die Geometrie liefert.

SQL: Standardwert ist leer. Sie können eine SQL-Anweisung definieren, um die Geometrie verwandter untergeordneter Features anzuzeigen, die in einer anderen Tabelle gespeichert sind. Dies geschieht beispielsweise, wenn die Tabelle vom Attributtyp ist, wie dies im Gebrauchsmuster der Fall ist. Beachten Sie die Parallele zu Beschriftungsdefinitionen. Mit einem Geometriesteuerelement zusätzlich zu SQL können Sie die Koordinaten der zugehörigen Geometrie anzeigen. Mit einer select-Anweisung für übergeordnete Geometrie können Sie die Geometrie eines verwandten Elementes abfragen, wenn die übergeordnete Bezeichnung vom Attributtyp ist.

Script Button

Verwenden Sie das Script Programmable -Steuerelement (Script Button), um kleine Skripts auszuführen. Seine Funktion ähnelt dem Formula TextBox-Steuerelement. Sie können VB .NET und die API in den Skripts verwenden.

Beispielscript:
dim c as MapEdit.Forms.DialogControls.ComboBox
c = Me.Dialog.Controls.Item("Fid_Street")
Msgbox( "The Street has the Fid:" & c )
Document Manager

Der Dokumenten Manager ist nicht mit einem Datenbankattribut der aktuellen Tabelle verknüpft. Dieses Steuerelement fügt eine Schaltfläche mit der Anzahl der zugewiesenen Dokumente ein (Dokumente, die mit dem Dokumentenmanager zugewiesen wurden). Wenn der Benutzer auf die Schaltfläche klickt, wird der Dokumentenmanager geöffnet, wobei zugewiesene Dokumente gefiltert werden.

AvailabelColor: Die Farbe, wenn Dokumente verfügbar sind.

AvailableValue: Meldung, die auf der Schaltfläche angezeigt wird.

UnvailableValue: Die zurückgegebene Nachricht, wenn keine Dokumente gefunden werden.

Fid Button

Ein Fid Button ist nicht mit einem Datenbankattribut verknüpft, das zur aktuellen Tabelle gehört. Mit diesem Steuerelement können Sie ein Feature in der Karte auswählen und ein Attribut mit diesem Wert füllen (Dies entspricht dem Abrufen verwandter Features, indem Sie sie einfach in der Karte auswählen). Normalerweise würden Sie jedoch ein verwandtes Feature aus einem einfachen Kombinationsfeld auswählen, z. B. ein Detail, das zu einem Schacht gehört.

DetailFieldName: Gibt den Namen des Datenbankattributs an, das mit dem FID gefüllt werden soll. Beispiel: FID_DETAIL.

DetailFilter: Filter-Anweisung (optional): Die SQL-Anweisung, die als Ergebnis eine andere FID erhält. Beispiel: Sie möchten ein Feature in der Karte auswählen, aber den FID seines übergeordneten Elements in das Attribut einfüllen. Verwenden Sie den SQL-Editor, um die filter-Anweisung zu definieren. Wählen Sie FID vom übergeordneten Element aus, wobei FID_CHILD={Fid}Hinweis: Bei {FID} wird zwischen Groß- und Kleinschreibung unterschieden. Der {FID} wird zur Laufzeit durch die ausgewählte FID ersetzt.

DetailTable: Gibt die Feature-Classes an, die in der Karte auswählbar sein sollen. Verwenden Sie diese Option, wenn Sie mehr als eine Feature-Class benötigen, z.Bsp:  {FeatureC1,FeatureC2,FeatureC3}

Highlight Button

Verwenden das HighlightButton – Steuerelement , um ein Feature in der Karte hervorzuheben, das sich nicht in der aktuellen Tabelle befindet, aber mit dem Datenbankattribut mit einer Beziehung verknüpft ist. Dieses Steuerelement funktioniert ähnlich wie das FID Button-Steuerelement, hebt jedoch eine Funktion hervor. Es ist eine spezielle Variante der Combo-Box-Highlight-Schaltfläche.

Beispiel aus einer Abwasseranwendung: Verwenden Sie den Feature-Highlighter in der Schnitt-Feature-Class, die eine Beziehung zum Schacht am Schnittstartpunkt hat, um den Schacht hervorzuheben.

Sie können auch einen Filter verwenden, um eine Funktion hervorzuheben, die sich von der Funktion unterscheidet, bei der Sie die FID erhalten.

Fid Reference

Verwenden das FidReference – Steuerelement, um eine FID-Schaltfläche zu generieren. Wenn ein Benutzer auf diese Schaltfläche klickt, wird das Formular, zu dem der FID gehört, geöffnet, wobei der Filter auf den FID festgelegt ist. Anmerkung: Die FID ist einzigartig (Nur im Oracle Autodesk Datenmodell vorhanden) in der gesamten Datenbank. Daher können Sie mit dem FidReference – Steuerelement dynamische Beziehungen erstellen. Verwenden Sie die Tabelle TB_UFID, um zu sehen, welcher FID zu welcher Feature-Class gehört.

Multi Referenz

Sie verwenden Multi Reference -Steuerelemente auf die gleiche Weise wie Reference -Steuerelemente. Der Unterschied besteht darin, dass Multibeziehungen verwendet werden können. Das heißt, mit einer Schaltfläche können Sie mehr als ein Formular gleichzeitig öffnen.

Das Multi Reference -Steuerelement generiert zwei Schaltflächen: die Schaltfläche Referenz und die Schaltfläche Projektion. Wenn der Benutzer auf die Schaltfläche Referenz drückt, wird das Formular aller zugehörigen Tabellen geöffnet, wobei ein Filter auf den aktuellen Datensatz festgelegt ist.

DetailRelations: Wählen Sie hier die Beziehungen / Formulare aus

ProjectionButton: Standardwert = true

ReferenceButton: Standardwert = true

Complex Referenz

Das ComplexReference -Steuerelement ist nicht mit einem Datenbankattribut der aktuellen Tabelle verknüpft. Mit ComplexReference können Sie das Formular einer anderen Tabelle mithilfe eines Filters öffnen. Sie können diesen Filter mithilfe komplexer SQL-Anweisungen definieren. Testen Sie daher die SQL-Anweisung im SQL-Assistenten.

DetailTable: Gibt die Tabelle an, die Sie öffnen möchten. Wählen Sie die Tabelle aus.

Filter: Definiert den Filter, der ausgeführt wird. Legen Sie die Werte fest, die in {} ersetzt werden sollen. Klicken Sie auf die … , um den SQL-Editor zu öffnen. Beispiel: FID = {FID_CHILD}

Sie können das ComplexReference-Steuerelement mit Eingabeparametern verwenden, z. B. einem Radius, zu dessen Eingabe der Benutzer aufgefordert wird. Ein Eingabefeld wird angezeigt. Wenn der Parameter ein numerischer Wert ist, müssen Sie das Zeichen # verwenden. Wenn es sich um einen Textwert handelt, verwenden Sie das Zeichen $.

Beispiel: {#Radius} {$Name}

SDO_WITHIN_DISTANCE(a.Geom,
(select geom from LM_POINT where fid={fid}) ,
'distance = {#Radius}') = 'TRUE
Line

Verwenden Sie das Steuerelement Line (Linie), um horizontale und vertikale Linien mit verschiedenen Eigenschaften zu zeichnen. In den Eigenschaften definieren Sie die Lage und das Aussehen der Linie.

Model Box

Verwenden Sie das Modellauswahl-Steuerelement, um die Modellauswahl einem Feature-Class-Formular hinzuzufügen. Sie erhalten ein Feld mit zwei Schaltflächen ÖFFNEN und ÜBERNEHMEN.

Der „ÖFFNEN“ Button öffnet den Dialog der Model Maske.

Der „ÜBERNEHMEN“ Button übernimmt aus dem offenen Model Dialog
den aktuellen Datensatz.

Abhängige Formatierung: Damit kann man die Control-Textfarbe oder Hintergrundfarbe mittels SQL „WHERE“ Bedingung formatieren. Beispiel: Wenn Bedingung: fid = 14, dann Hintergrund blau färben, sonst grün färben.

Static Picture

Verwenden Sie das StaticPicturebox-Steuerelement, um Bilder im Feature-Class-Formular anzuzeigen, z. B. Ihr Firmenlogo.

Filename: Gibt das Verzeichnis und den Dateinamen des Bilds an, das im Formular angezeigt werden soll (*.gif*.bmp usw.).

StretchImage: Gibt an, wie das Bild angezeigt wird. Bei True wird das Bild auf die Größe des Steuerelements gestreckt. Wenn False, wird das Bild in Originalgröße angezeigt.

Anmerkung: Obwohl die Bilddateien in jedem Ordner gespeichert werden können, wird empfohlen, sie in einem Unterordner zu speichern. Wenn Sie Bilddateien mit einem statischen Pfad verwenden, sind sie auf einem anderen Computer nur verfügbar, wenn der Pfad genau derselbe ist. Alternativ können Sie //Servername verwenden, um die Bilddateien auf einem Server zu speichern. Die Dimension des jeweiligen Datenbankattributs muss groß genug sein, um die Verzeichnisnamen zu speichern.

Picture Box

Das Steuerelement Picture Box – Steuerelement ist mit einem Datenbankattribut verknüpft. Es zeigt datensatzbezogene Bilder (*.gif*.bmpusw.). Im Formular kann der Benutzer ein Listenfeld verwenden, um ein Bild auszuwählen. Wenn das Bild ausgewählt ist, werden die Verzeichnis- oder Pfadnamen der Bilder in der Datenbank gespeichert.

HideText: Gibt an, ob der Listenfeldtext ausgeblendet ist. Legen Sie den Satz auf True fest, um das Listenfeld mit dem Dateinamen auszublenden und nur das Bild anzuzeigen. Diese Eigenschaft funktioniert nur im Ansichtsmodus. Standard = False.

StretchImage: Gibt an, wie das Bild angezeigt wird. Bei True wird das Bild auf die Größe des Steuerelements gestreckt. Wenn False, wird das Bild in Originalgröße angezeigt.

Anmerkung: Obwohl die Bilddateien in jedem Ordner gespeichert werden können, wird empfohlen, sie in einem Unterordner zu speichern. Wenn Sie Bilddateien mit einem statischen Pfad verwenden, sind sie auf einem anderen Computer nur verfügbar, wenn der Pfad genau derselbe ist. Alternativ können Sie //Servername verwenden, um die Bilddateien auf einem Server zu speichern. Die Dimension des jeweiligen Datenbankattributs muss groß genug sein, um die Verzeichnisnamen zu speichern.

Api Control

Die API Control ist ein Platzhalter für ein Control das ein Fremdentwickler via Plugin einfügen möchte. D.h. ein Fremdentwickler kann hier ein beliebiges eigenes Control (das eine beliebige Funktion hat) bereitstellen. Diese fügt dann zur Laufzeit ihren Wert dort ein wo das Platzhaltercontrol steht.

Ein Beispiel finden Sie in dem Installationsverzeichnis von MapEdit unter ……..\ApiSamples\104 Dialog Plugin\MyApiControlPlugIn.cs

ControlProperties: Hier kann man das API Controll des Fremdentwicklers weiter konfigurieren wenn notwendig. Das ist ein einfacher Text der vom Control ausgewertet wird. Was hier eingetragen wird legt der Fremdentwickler fest.

Abhängige Formatierung: Damit kann man die Control-Textfarbe oder Hintergrundfarbe mittels SQL „WHERE“ Bedingung formatieren. Beispiel: Wenn Bedingung: fid = 14, dann Hintergrund blau färben, sonst grün färben.

Picture ComboBox

Dieses Steuerelement ist mit einem Datenbankattribut verknüpft. Sie verwenden das Picture ComboBox-Steuerelement, um Bilddateien, die in einem Verzeichnis gespeichert sind, in einem Kombinationsfeld anzuzeigen.

ItemHeight: Gibt die Größe (Höhe) des Bilds in Pixel in der Liste an.

ItemWidth: Gibt die Größe (Breite) des Bilds in Pixel in der Liste an.

PictureDirectory: Gibt das Verzeichnis an, das die Bilddateien enthält, die Sie im Listenfeld bereitstellen möchten.

Anmerkung: Obwohl die Bilddateien in jedem Ordner gespeichert werden können, wird empfohlen sie in einem Unterordner zu speichern. Wenn Sie Bilddateien mit einem statischen Pfad verwenden, sind sie auf einem anderen Computer nur verfügbar, wenn der Pfad genau derselbe ist. Alternativ können Sie //Servername verwenden, um die Bilddateien auf einem Server zu speichern.

Reiter Extras

Folgende Bearbeitungsmöglichkeiten stehen unter Menüpunkt Extras zur Verfügung:

Vorschau

In der Vorschau erhalten Sie die Ausprägung des Dialog’s wie er in MapEdit zu sehen ist.

Tab Berechtigungen

Diese Funktion schaltet auf die Karteikarte Register um. Hier haben Sie die Möglichkeit für die einzelnen Tabs im Formular Zugriffsrechte zu vergeben. Mit ADD fügen Sie einem Formular einen neuen Tab hinzu dem Sie dann weitere Berechtigungen vergeben können. Mit REMOVE entfernen Sie einen Tab aus dem Formular und mit RENAME benennen Sie einen Tab um.

Dialog Eigenschaften

Diese Funktion schaltet auf die Karteikarte Optionen um und bekommen eine Übersicht über verfügbare Detailformulare die man in das Hauptformular einbinden kann.

Updated on September 9, 2021